Domain Certificate Issue

Incident Report for Xen Education

Postmortem

A new certificate was created by the DevOps team and the sites were back to live at 2:15 pm.

What was the incident’s duration?

The incident lasted 1.5 hours from discovery to remediation.

The exposure occurred at 5:29:59 AM IST.

Were there any consequences or damages?

Users couldn’t access the site.

How was the incident addressed?

New certificate was created.

What will prevent further similar incidents?

The auto-renewal configuration was reviewed with the upstream cloud services provider and a new private local domain policy was implemented to minimise the risk of a public domain’s availability impacting the overall platform stability.

Posted Jun 25, 2024 - 17:56 AEST

Resolved

Domain Certificate for a core Xen service expired due to a configuration error. When the domain could not be renewed, the associated service could not be reached.
Posted Jan 05, 2023 - 12:00 AEDT