We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 15:00 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 12:09 AEDT
Investigating
Amazon Web Services (AWS) - the global Cloud infrastructure hosting Xen and many other platforms - is currently experiencing outages affecting most of the World Wide Web. We are monitoring the situation closely.
At this stage, some Xen services are experiencing slowness in some of the Eastern US regions. While the disruption is primarily impacting the US, it may also cause intermittent issues in other regions we operate in as the load is balanced.
We understand this is disruptive and are committed to keeping you updated via our Status Page as new information becomes available.
Posted Oct 21, 2025 - 12:08 AEDT
This incident affected: North America region (Learning Portals, Authoring Tool, API, Reporting, E-commerce & Payments, Notifications Services (emails), Distributed Task Queue services, Import & Export jobs).