H5P navigation error

Incident Report for Xen Education

Postmortem

What happened?

On Feb 20 at 12:00 pm UTC production deployment was started to handle H5P CSV files via S3 and skip H5P questions functionality for learners who completed H5P questions. Deployment was completed at 2.30 pm UTC.

On Feb 21 at 2:23 pm UTC, the Xen team received reports that some learners could not navigate to the next slide after completing H5P quizzes.

At 2:30 pm UTC the Xen team started to investigate the issue.

At 2:54 pm UTC the Xen team reverted the newly deployed production to the previous AMI image to mitigate the impact and restore functionality to the learners, which was achieved at 3:04 pm UTC.

Why did this happen?

This incident was related to the functionality of skipping H5P questions for learners who have completed them, whereas an edge case scenario was not fully tested.

Specifically, when a learner attempts the last H5P question in a lesson with a continuous flow and subsequently navigates back to the attempted H5P (result page) using the previous button, clicking the next button on the result page loads the same H5P page instead of navigating to the next slide.

What was the incident’s duration?

The incident lasted 41 minutes from discovery to remediation.

Were there any consequences or damages?

Learners could not navigate to the next slide after submitting a Drag & Drop quiz. One learner was reported having been impacted by this issue.

What will prevent further similar incidents?

  • The Development and QA team should note the possible edge case scenario for the respective feature.
  • The Development team should complete all checklists provided by the QA team.
  • QA team should test every possible scenario related to the feature, following that, a sanity test must be conducted on the environment
Posted Jun 25, 2024 - 17:03 AEST

Resolved

An issue was raised by a customer via the Customer Support Portal stating that learners could not navigate to the next page after completing a H5P quizz.
Posted Feb 20, 2024 - 00:30 AEDT